android - Emulator: ERROR: x86 emulation currently requires hardware acceleration

ID : 10159

viewed : 203

Tags : androidandroid-emulatorintelhaxmandroid

Top 5 Answer for android - Emulator: ERROR: x86 emulation currently requires hardware acceleration

vote vote

92

As per this response, the complete steps are:

1) Open SDK Manager (In Android Studio, go to Tools > Android > SDK Manager) and Download Intel x86 Emulator Accelerator (HAXM installer) if you haven't.

Intel x86 Emulator Accelerator (HAXM installer)

2) Now go to your SDK directory C:\users\%USERNAME%\AppData\Local\Android\sdk\extras\intel\Hardware_Accelerated_Execution_Manager\ and run the file named intelhaxm-android.exe.

In case you get an error like "Intel virtualization technology (vt,vt-x) is not enabled". Go to your BIOS settings and enable Hardware Virtualization.

3) Restart Android Studio and then try to start the AVD again.

It might take a minute or 2 to show the emulator window.

vote vote

80

[edit] The Android developer page has been updated with an excellent guide to get an emulator up and running. [/edit]

Install the Intel x86 Emulator Accelerator using the Android SDK Manager

Android SDK Manager

If you have Android Studio installed, you can start the SDK manager via Tools -> Android -> SDK Manager.

The Android SDK Manager does not actually install HAXM, it just downloads it. In the top of the Android SDK manager window, you can find where the installer is located on your PC. Please open the subfolder extras\intel\Hardware_Accelerated_Execution_Manager, and run the installer manually: intelhaxm-android.exe.

To use the intel HAXM, you need to have a CPU with virtualization support:

Before attempting to use this type of acceleration, you should first determine if your development system’s CPU supports one of the following virtualization extensions technologies:

  • Intel Virtualization Technology (VT, VT-x, vmx) extensions
  • AMD Virtualization (AMD-V, SVM) extensions (only supported for Linux)

[edit] As of Nov 27, 2019, Google has released an emulator for AMD CPUs. [/edit]

If your CPU does not have virtualization support, you could use an ARM emulator instead:

You can edit an existing, or add a new Virtual Device in the Android Virtual device Manager, and change CPU/ABI to ARM. If that option is not available, you may need to change the target API of the Virtual Device, or download an ARM system image for the API version you want using the Android SDK manager.

vote vote

74

I was able to resolve my problem of the missing acceleration with the following workflow on Windows 10, Lenovo, Intel Core i7 CPU:

Changed to the HAXM setup folder: C:\Users\\AppData\Local\Android\Sdk\extras\intel\Hardware_Accelerated_Execution_Manager

Opened a cmd (MS-DOS) shell Window and executed haxm_check.exe to check whether CPU supports HAXM - it outputs in my case:

VT support -- yes NX support -- yes 

So, I knew this most be a setup problem. So, I started the setup program intelhaxm-android.exe in the same folder with Admin account and removed the installed components. After that, I've attempted to re-install with the same setup program and got this output:

HAXM Supported but not turned on So, I went into the CPU section of the BIOS and turned on acceleration/Virtualization - went back to the setup program and re-ran it, this time I was pleased to see this output:

enter image description here

After that, I restarted Android Studio and used Tools>AVD Manager to define a new image for an emulator. I was then able to see the emulator starting up succesfully by clicking the play button in the list of emulators in the AVD Manager's list:

enter image description here

or by - Opening a sample project that compiles OK - using File > Sync Project with Gradle Files (to build all artifacts) - Select the app item in the Android (TW) and click Run > Run 'app' - Select the previously configured Emaulator showed me this :-)

Hope this helps to troubleshoot others with their problems that are really caused by a bad setup implementation since the missing acceleration option was silently swallowed by the Android Studio setup program ... :-(

enter image description here

vote vote

62

Simple Solution :

Open Android SDK manager, on top side you can see the "Android SDK Location" go to that location and follow this path

\extras\intel\Hardware_Accelerated_Execution_Manager

here you will get "intelhaxm-android.exe" install this setup.

vote vote

58

If you are using an AMD CPU, AMD Virtualization (CPUs such as Ryzen) is now officially supported. Make sure you have virtualization switched on in the BIOS.

In "Turn Windows Features On or Off" (you can find it through Windows Search), you'll need to enable

Once you restart and start up the emulator (an x86 build), it should start booting up without the mentioned error.

Top 3 video Explaining android - Emulator: ERROR: x86 emulation currently requires hardware acceleration

Related QUESTION?