tmux set -g mouse-mode on doesn't work

ID : 10366

viewed : 22

Tags : tmuxtmux

Top 5 Answer for tmux set -g mouse-mode on doesn't work

vote vote

90

So this option has been renamed in version 2.1 (18 October 2015)

From the changelog:

 Mouse-mode has been rewritten.  There's now no longer options for:     - mouse-resize-pane     - mouse-select-pane     - mouse-select-window     - mode-mouse    Instead there is just one option:  'mouse' which turns on mouse support 

So this is what I'm using now in my .tmux.conf file

set -g mouse on 
vote vote

90

As @Graham42 noted, mouse option has changed in version 2.1. Scrolling now requires for you to enter copy mode first. To enable scrolling almost identical to how it was before 2.1 add following to your .tmux.conf.

set-option -g mouse on  # make scrolling with wheels work bind -n WheelUpPane if-shell -F -t = "#{mouse_any_flag}" "send-keys -M" "if -Ft= '#{pane_in_mode}' 'send-keys -M' 'select-pane -t=; copy-mode -e; send-keys -M'" bind -n WheelDownPane select-pane -t= \; send-keys -M 

This will enable scrolling on hover over a pane and you will be able to scroll that pane line by line.

Source: https://groups.google.com/d/msg/tmux-users/TRwPgEOVqho/Ck_oth_SDgAJ

vote vote

72

Just a quick heads-up to anyone else who is losing their mind right now:

https://github.com/tmux/tmux/blob/310f0a960ca64fa3809545badc629c0c166c6cd2/CHANGES#L12

so that's just

 :setw -g mouse 
vote vote

61

this should work:

setw -g mode-mouse on 

then resource then config file

tmux source-file ~/.tmux.conf 

or kill the server

vote vote

56

Paste here in ~/.tmux.conf

set -g mouse on 

and run on terminal

tmux source-file ~/.tmux.conf 

Top 3 video Explaining tmux set -g mouse-mode on doesn't work

Related QUESTION?