visual studio 2010 - UTF-8 without BOM

ID : 20153

viewed : 28

Tags : visual-studio-2010visual-studiobyte-order-markvisual-studio-2010visual-studio

Top 5 Answer for visual studio 2010 - UTF-8 without BOM

vote vote

92

BOM or Byte Order Mark is sometimes quite annoying. Visual Studio does not change the file unless you save it (as Hans said).

And here is the solution to your problem: If you want to save a file with other encodings, select save as and extend the save button in file dialog and select "Save with encoding". Or if you want to get rid of this setting permanently, just open File menu and select "Advanced save options" and there you should select "UTF-8 without signature" (and that also answered your last question :). Yes "UTF-8 without signature" is same as without BOM.

vote vote

83

Now with pictures.

  1. Go to File -> Save As.

    File/Save As

  2. Then on Save button click on triangle and click Save with Encoding....

    Save with Encoding

  3. Click ok to overwrite the file then from list of encodings find UTF-8 Without signature -> Click OK.

    UTF-8 Without signature

Hope this saves you some time.

vote vote

80

I've created the Fix File Encoding extension that prevents Visual Studio 2010+ from adding BOM to UTF-8 files.

vote vote

63

Unfortunately this does not work with csproj files. There is no "Advanced save option" and even though you have set it to "UTF-8 without signature" for a cs file, csproj files still are saved with BOM. If you use VSS it still complains about project files.

vote vote

53

UTF-8 - "Save As" (Without Signature) Default - Request to include Default for UTF Without Signature

VS 2017 natively supports EditorConfig so a recommended solution is to add .editorconfig file to your code base and set charset => utf-8. Then once you save a file it will be saved as UTF-8 without BOM.

Top 3 video Explaining visual studio 2010 - UTF-8 without BOM

Related QUESTION?