php and apache thread safe error

ID : 274542

viewed : 25

Tags : phpapachephp





Top 4 Answer for php and apache thread safe error

vote vote

99

Disabling mpm_event and enabling mpm_prefork worked for me.

sudo a2dismod mpm_event sudo a2enmod mpm_prefork 
vote vote

89

Test the Apache configuration:

apache2ctl configtest 

Install PHP and PHP-FPM:

sudo apt-get install php7.0 sudo apt-get install php7.0-fpm 

Enable Apache PHP7 module:

sudo a2enmod php7.0 

Disable mpm_event module:

sudo a2dismod mpm_event 

Enable mpm_prefork module:

sudo a2enmod mpm_prefork 

Finally restart Apache:

sudo service apache2 restart 

This will resolve your error.

vote vote

75

The PHP manual does not recommend this

You can run a fast-CGI version of PHP though:

apt-get install php5-fpm should install it for you.

vote vote

63

Top 3 video Explaining php and apache thread safe error







Related QUESTION?